Commit 88cb3664 authored by Jonathan Wilkes's avatar Jonathan Wilkes
Browse files

Merge branch 'use-debbuild' into list-store

parents 97e23c77 13a884d6
...@@ -12,18 +12,16 @@ BUILDLAYOUT_DIR = $(cvs_root_dir)/packages ...@@ -12,18 +12,16 @@ BUILDLAYOUT_DIR = $(cvs_root_dir)/packages
include $(BUILDLAYOUT_DIR)/Makefile.buildlayout include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
# if machine has dpkg-deb, build a Debian package # if machine has dpkg-deb, build a Debian package
#ifeq ($(shell test -x /usr/bin/dpkg-deb && echo YES),YES) ifeq ($(shell test -x /usr/bin/dpkg-deb && echo YES),YES)
# PACKAGE_TYPE = deb PACKAGE_TYPE = deb
#else else
# PACKAGE_TYPE = tarbz2 PACKAGE_TYPE = tarbz2
#endif endif
# for command-line UNIX versions, you need to install Pd into the same # for command-line UNIX versions, you need to install Pd into the same
# directory as $(prefix) otherwise Pd won't be able to find extra, doc, etc. # directory as $(prefix) otherwise Pd won't be able to find extra, doc, etc.
ifeq ($(PACKAGE_TYPE),deb) ifeq ($(PACKAGE_TYPE),deb)
prefix = /usr prefix = /usr
# generates the dependencies for all externals and pd itself
PACKAGE_DEPENDS := $(shell find $(DESTDIR) \( -name "*.pd_linux" -or -name pd-gui -or -wholename \*bin/pd \) -print0 | xargs -0 dpkg-shlibdeps -O | sed 's|shlibs:Depends=|, |' )
else else
prefix = /usr/local prefix = /usr/local
endif endif
...@@ -160,6 +158,9 @@ deb: debstage ...@@ -160,6 +158,9 @@ deb: debstage
cp $(packages_src)/linux_make/debian/control $(DESTDIR)/DEBIAN cp $(packages_src)/linux_make/debian/control $(DESTDIR)/DEBIAN
cp $(packages_src)/linux_make/debian/pd-l2ork.postrm $(DESTDIR)/DEBIAN cp $(packages_src)/linux_make/debian/pd-l2ork.postrm $(DESTDIR)/DEBIAN
cp $(packages_src)/linux_make/debian/pd-l2ork.postinst $(DESTDIR)/DEBIAN cp $(packages_src)/linux_make/debian/pd-l2ork.postinst $(DESTDIR)/DEBIAN
# generate the dependencies for all externals and pd itself
$(eval PACKAGE_DEPENDS := $(shell find $(DESTDIR) \( -name "*.pd_linux" -or -name pd-gui -or -wholename \*bin/pd \) -print0 | xargs -0 dpkg-shlibdeps -O | sed 's|shlibs:Depends=|, |' ))
# set build architecture and version for the package # set build architecture and version for the package
sed -i 's|^Version:.*|Version: $(DEB_PD_VERSION)|' \ sed -i 's|^Version:.*|Version: $(DEB_PD_VERSION)|' \
$(DESTDIR)/DEBIAN/control $(DESTDIR)/DEBIAN/control
...@@ -279,7 +280,7 @@ test_locations: ...@@ -279,7 +280,7 @@ test_locations:
@echo "EXAMPLESDIR $(examplesdir)" @echo "EXAMPLESDIR $(examplesdir)"
@echo -------------------------------------------------- @echo --------------------------------------------------
# @echo "PACKAGE_DEPENDS $(PACKAGE_DEPENDS)" # @echo "PACKAGE_DEPENDS $(PACKAGE_DEPENDS)"
# @echo -------------------------------------------------- @echo --------------------------------------------------
autoconf --version autoconf --version
@echo -------------------------------------------------- @echo --------------------------------------------------
make --version make --version
......
...@@ -6,7 +6,7 @@ Maintainer: Ivica Ico Bukvic <ico@vt.edu> ...@@ -6,7 +6,7 @@ Maintainer: Ivica Ico Bukvic <ico@vt.edu>
Homepage: http://l2ork.music.vt.edu Homepage: http://l2ork.music.vt.edu
Package: pd-l2ork Package: pd-l2ork
Architecture: i386 Architecture: i386
Depends: libc6, xterm | x-terminal-emulator, libasound2, libjack-jackd2-0, libbluetooth3, libgl1-mesa-glx, libgl1-mesa-dri, libglu1-mesa, libftgl2, libgmerlin0, libgmerlin-avdec1, libavifile-0.7c2, libmpeg3-1 | libmpeg3-2, libquicktime2, libv4l-0, libraw1394-11, libdc1394-22, libfftw3-3, libvorbis0a, libmp3lame0, libspeex1, libgsl0ldbl | libgsl2, python, libsmpeg0, libjpeg62, libflite1, libgsm1, libxv1, fluid-soundfont-gm, byacc Depends: python, fluid-soundfont-gm
Provides: pd-l2ork Provides: pd-l2ork
Installed-Size: 90624 Installed-Size: 90624
Recommends: xdg-utils, pulseaudio-utils, tap-plugins, ladspa-foo-plugins, invada-studio-plugins-ladspa, blepvco, swh-plugins, mcp-plugins, cmt, blop, slv2-jack, omins, ubuntustudio-audio-plugins, rev-plugins, dssi-utils, vco-plugins, wah-plugins, fil-plugins, mda-lv2 Recommends: xdg-utils, pulseaudio-utils, tap-plugins, ladspa-foo-plugins, invada-studio-plugins-ladspa, blepvco, swh-plugins, mcp-plugins, cmt, blop, slv2-jack, omins, ubuntustudio-audio-plugins, rev-plugins, dssi-utils, vco-plugins, wah-plugins, fil-plugins, mda-lv2
......
...@@ -6,7 +6,7 @@ Maintainer: Ivica Ico Bukvic <ico@vt.edu> ...@@ -6,7 +6,7 @@ Maintainer: Ivica Ico Bukvic <ico@vt.edu>
Homepage: http://l2ork.music.vt.edu Homepage: http://l2ork.music.vt.edu
Package: pd-l2ork Package: pd-l2ork
Architecture: i386 Architecture: i386
Depends: libc6, xterm | x-terminal-emulator, libasound2, libjack-jackd2-0, libbluetooth3, libgl1-mesa-glx, libgl1-mesa-dri, libglu1-mesa, libftgl2, libgmerlin0, libgmerlin-avdec1, libavifile-0.7c2, libmpeg3-1 | libmpeg3-2, libquicktime2, libv4l-0, libraw1394-11, libdc1394-22, libfftw3-3, libvorbis0a, libmp3lame0, libspeex1, libgsl0ldbl | libgsl2, python, libsmpeg0, libjpeg62, libflite1, libgsm1, libxv1, fluid-soundfont-gm, byacc Depends: python, fluid-soundfont-gm
Provides: pd-l2ork Provides: pd-l2ork
Installed-Size: 90624 Installed-Size: 90624
Recommends: xdg-utils, pulseaudio-utils, tap-plugins, ladspa-foo-plugins, invada-studio-plugins-ladspa, blepvco, swh-plugins, mcp-plugins, cmt, blop, slv2-jack, omins, ubuntustudio-audio-plugins, rev-plugins, dssi-utils, vco-plugins, wah-plugins, fil-plugins, mda-lv2 Recommends: xdg-utils, pulseaudio-utils, tap-plugins, ladspa-foo-plugins, invada-studio-plugins-ladspa, blepvco, swh-plugins, mcp-plugins, cmt, blop, slv2-jack, omins, ubuntustudio-audio-plugins, rev-plugins, dssi-utils, vco-plugins, wah-plugins, fil-plugins, mda-lv2
......
...@@ -6,7 +6,7 @@ Maintainer: Ivica Ico Bukvic <ico@vt.edu> ...@@ -6,7 +6,7 @@ Maintainer: Ivica Ico Bukvic <ico@vt.edu>
Homepage: http://l2ork.music.vt.edu Homepage: http://l2ork.music.vt.edu
Package: pd-l2ork Package: pd-l2ork
Architecture: i386 Architecture: i386
Depends: xterm | x-terminal-emulator, libasound2, libjack-jackd2-0, libbluetooth3, libgl1-mesa-glx, libglu1-mesa, libftgl2, libgmerlin0, libgmerlin-avdec1, libavifile-0.7c2, libmpeg3-1 | libmpeg3-2, libquicktime2, libv4l-0, libraw1394-11, libdc1394-22, libfftw3-3, libvorbis0a, libmp3lame0, libspeex1, libgsl0ldbl, python, libsmpeg0, libjpeg62, tkpng, libflite1, libgsm1, libxv1, fluid-soundfont-gm, byacc Depends: python, fluid-soundfont-gm
Provides: pd-l2ork Provides: pd-l2ork
Installed-Size: 90624 Installed-Size: 90624
Recommends: xdg-utils, pulseaudio-utils, tap-plugins, ladspa-foo-plugins, invada-studio-plugins-ladspa, blepvco, swh-plugins, mcp-plugins, cmt, blop, slv2-jack, omins, ubuntustudio-audio-plugins, rev-plugins, dssi-utils, vco-plugins, wah-plugins, fil-plugins, mda-lv2 Recommends: xdg-utils, pulseaudio-utils, tap-plugins, ladspa-foo-plugins, invada-studio-plugins-ladspa, blepvco, swh-plugins, mcp-plugins, cmt, blop, slv2-jack, omins, ubuntustudio-audio-plugins, rev-plugins, dssi-utils, vco-plugins, wah-plugins, fil-plugins, mda-lv2
......
...@@ -6,7 +6,7 @@ Maintainer: Ivica Ico Bukvic <ico@vt.edu> ...@@ -6,7 +6,7 @@ Maintainer: Ivica Ico Bukvic <ico@vt.edu>
Homepage: http://l2ork.music.vt.edu Homepage: http://l2ork.music.vt.edu
Package: pd-l2ork Package: pd-l2ork
Architecture: i386 Architecture: i386
Depends: xterm | x-terminal-emulator, libc6 (>= 2.1.5), libasound2, libjack-jackd2-0, libbluetooth3, libgl1-mesa-glx, libgl1-mesa-dri, libglu1-mesa, libglew1.5, libmagick++4, libftgl2, libgmerlin0, libgmerlin-avdec1, libavifile-0.7c2, libmpeg3-1, libquicktime2, libv4l-0, libraw1394-11, libdc1394-22, libfftw3-3, libvorbis0a, libmp3lame0, libspeex1, libgsl0ldbl, python, libsmpeg0, libjpeg62, libflite1, libgsm1 Depends: python, fluid-soundfont-gm
Provides: pd-l2ork Provides: pd-l2ork
Installed-Size: 90624 Installed-Size: 90624
Recommends: xdg-utils, pulseaudio-utils, tap-plugins, ladspa-foo-plugins, invada-studio-plugins-ladspa, blepvco, swh-plugins, mcp-plugins, cmt, blop, slv2-jack, omins, ubuntustudio-audio-plugins, rev-plugins, dssi-utils, vco-plugins, wah-plugins, fil-plugins, mda-lv2 Recommends: xdg-utils, pulseaudio-utils, tap-plugins, ladspa-foo-plugins, invada-studio-plugins-ladspa, blepvco, swh-plugins, mcp-plugins, cmt, blop, slv2-jack, omins, ubuntustudio-audio-plugins, rev-plugins, dssi-utils, vco-plugins, wah-plugins, fil-plugins, mda-lv2
......
...@@ -46,7 +46,7 @@ void sys_doflags( void); ...@@ -46,7 +46,7 @@ void sys_doflags( void);
#ifdef UNIX #ifdef UNIX
#define USER_CONFIG_DIR ".pd-l2ork" #define USER_CONFIG_DIR ".purr-data"
static char *sys_prefbuf; static char *sys_prefbuf;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment