Commit 8ffe700f authored by Jonathan Wilkes's avatar Jonathan Wilkes
Browse files

clean up README and try to prune unneeded compile dependencies

parent 46ffba37
## Pd-L2Ork
maintainer: Ivica Ico Bukvic <ico@vt.edu>
maintainers:
maintainer: Albert Graef <aggraef@gmail.com>
* Ivica Ico Bukvic <ico@vt.edu>
* Albert Graef <aggraef@gmail.com>
* Jonathan Wilkes <jancsika@yahoo.com>
maintainer: Jonathan Wilkes <jancsika@yahoo.com>
[Downloads](https://github.com/jonwwilkes/purr-data/releases)
[Mailing List](http://disis.music.vt.edu/cgi-bin/mailman/listinfo/l2ork-dev)
......@@ -90,24 +92,20 @@ from the following site:
Time to build: *40 minutes to 1.5 hours*
Hard drive space required: *roughly 2.5 GB*
1. Install the dependencies
sudo apt-get install bison flex automake qjackctl \
tcl8.5-dev tk8.5-dev tcl-dev tk-dev libasound2-dev \
libjack-jackd2-dev libtool libbluetooth-dev libgl1-mesa-dev \
libglu1-mesa-dev libglew-dev libmagick++-dev libftgl-dev \
libgmerlin-dev libgmerlin-avdec-dev libavifile-0.7-dev \
libmpeg3-dev libquicktime-dev libv4l-dev libraw1394-dev \
libdc1394-22-dev libfftw3-dev libvorbis-dev ladspa-sdk \
dssi-dev tap-plugins ladspa-foo-plugins \
invada-studio-plugins-ladspa blepvco swh-plugins mcp-plugins \
cmt blop slv2-jack omins ubuntustudio-audio-plugins rev-plugins \
libslv2-dev dssi-utils vco-plugins wah-plugins fil-plugins \
mda-lv2 libmp3lame-dev libspeex-dev libgsl0-dev \
portaudio19-dev python-dev libsmpeg0 libjpeg62 tkpng flite1-dev \
libgsm1-dev libfftw3-dev libgtk2.0-dev subversion git libstk0-dev \
libsndobj-dev libfluidsynth-dev tclxapian fluid-soundfont-gm \
python-tk byacc
1. Install the dependencies:
sudo apt-get install bison build-essential flex make automake qjackctl \
libasound2-dev libjack-jackd2-dev libtool fluid-soundfont-gm \
libtool libbluetooth-dev libgl1-mesa-dev libglu1-mesa-dev \
libglew-dev libmagick++-dev libftgl-dev libgmerlin-dev \
libgmerlin-avdec-dev libavifile-0.7-dev libmpeg3-dev \
libquicktime-dev libv4l-dev libraw1394-dev libdc1394-22-dev \
libfftw3-dev libvorbis-dev ladspa-sdk omins dssi-dev blepvco \
swh-plugins mcp-plugins cmt blop rev-plugins dssi-utils \
vco-plugins wah-plugins fil-plugins mda-lv2 libmp3lame-dev \
libspeex-dev libgsl-dev portaudio19-dev python-dev libsmpeg0 \
libjpeg62-turbo flite1-dev libgsm1-dev libfftw-dev git \
libstk0-dev libsndobj-dev libfluidsynth-dev byacc libgtk2.0-dev
2. Clone the Purr-Data repository *(10 minutes)*
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment