Commit b8a83e88 authored by Albert Gräf's avatar Albert Gräf

Change the pkg-config command to properly detect the Lua library also on Debian/Ubuntu.

parent ec056736
......@@ -1406,8 +1406,12 @@ pddp_clean:
#------------------------------------------------------------------------------#
# PDLUA
LUA_CFLAGS = $(shell (pkg-config --cflags lua5.3 || pkg-config --cflags lua5.2 || pkg-config --cflags lua) 2> /dev/null)
LUA_LIBS = $(shell (pkg-config --libs lua5.3 || pkg-config --libs lua5.2 || pkg-config --libs lua) 2> /dev/null)
pdlua:
make -C $(externals_src)/pd-lua LUA_CFLAGS="$(shell pkg-config --cflags lua)" LUA_LIBS="$(shell pkg-config --libs lua)" PD_PATH=$(pd_src) CFLAGS="$(CFLAGS)"
make -C $(externals_src)/pd-lua LUA_CFLAGS="$(LUA_CFLAGS)" LUA_LIBS="$(LUA_LIBS)" PD_PATH=$(pd_src) CFLAGS="$(CFLAGS)"
pdlua_install:
make -C $(externals_src)/pd-lua DESTDIR="$(DESTDIR)" objectsdir="$(objectsdir)" install
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment